Skip to content
Related Articles

Related Articles

OSPF Implementation

View Discussion
Improve Article
Save Article
  • Difficulty Level : Medium
  • Last Updated : 02 Jun, 2022
View Discussion
Improve Article
Save Article

OSPF stands for Open Shortest Path First a link-state protocol and as the name itself justifies that it is used to find the best and the optimal pathway between the starting point and the destination target router using its own shortest path first algorithm. It sends hello packets every 10 seconds. It varies under (LSRP) Link State Routing Protocol. It automatically generates or decides the optimal path and it is used to send router packets with the auto path decision method. It is one of the Interior gateway protocols that aim to move the packet within a large autonomous system. OSPF works on port no. 89 and uses [AD value 110].

OSPF creates or constructs a topological map of the network from the available router by gathering link-state routing protocol. OSPF also supports the Classless Inter-Domain Routing addressing system. The topology of the network is represented as a routing table to the Internet Layer for routing packets by their destination IP address.

 Uses of OSPF:

  • The idea behind the implementation of OSPF is to decrease or lower the amount of routing traffic and lower the tasks of core routers. 
  • OSPF supports both IPv4 and IPv6 and supports the classless CIDR addressing system, and is widely used in large enterprise networks.
  •  OSPF protocol has unlimited hop counts, unlike RIP protocol which has only 15 hops. 

Why is OSPF Better for Network Management?

OSPF is very reliable because of the strict division of level of routing as it has complete information on network topology and it also supports interface-based plaintext and md5 authentication.

Advantages of OSPF:

  • OSPF supports load balancing with equal costs routes.
  • Countless hope counts.
  • A true loop-free topology
  • Classless protocol.
  • Supports both IPv4 and IPv6 protocols. 
  • OSPF can be implemented in a single area or multi-area.
  • Provides Load-Balancing with equal cost-routes for the same destination.
  • OSPF supports both IPv4 as well as IPv6 protocols.
  • It decreases or lowers the overall amount of network traffic.
  • Provides the automatic generation and decision over the optimal path.
  • It triggers updates for fast convergence.
  • It runs on most routers.

Commands to Configuring OSPF:

(config)# router ospf<process ID>

(config-router)# network<network ID><wildcard mask>area<area ID>

Implement the OSPF Single Area Network:

Step 1: Initialize the interface and host with IP addresses and default gateway respectively:

  • Network topology consists of 3 Host, 3 Interfaces, and 3 switches
    • HOST1: IP 192.168.1.2, Default gateway: 192.168.1.1
    • HOST2: IP 192.168.2.2, Default gateway: 192.168.2.1
    • HOST3: IP 192.168.3.2, Default gateway: 192.168.3.1
 OSPF single area network

 

  •  As we can see we have configured interface 1 (Router0) with Host 1 which is PC0 and the Serial port.
IOS CLI

 

Step 2: Configuring the Interface 2 which is router1.

 

Step 3: Configuring the Interface 3 which is router2.

 

Now comes the main part now we have to configure the OSPF implementation:

Step 1: Configure the Router0 and create router OSPF 1 and then add network id with wildcard mask.

Router(config)#router ospf 1

Router(config-router)#network 192.168.1.0 0.255.255.255 area 0

Router(config-router)#network 10.0.0.0 0.0.0.255 area 0

 

Step2: Configure the Router1  and create router OSPF 1 and then add network id with wildcard mask.

Router(config)#router ospf 1

Router(config-router)#network 10.0.0.0 0.0.0.255 area 0

Router(config-router)#network 20.0.0.0 0.0.0.255 area 0

Router(config-router)#network 192.168.2.0 0.255.255.255 area 0

 

Step 3: Configure the Router2  and create router OSPF 1 and then add network id with wildcard mask.

Router(config)#router ospf 1

Router(config-router)#network 192.168.3.0 0.255.255.255 area 0

Router(config-router)#network 255.0.0.0 0.0.0.255 area 0

 

For more details please refer to OSPF router roles and configuration.

My Personal Notes arrow_drop_up
Recommended Articles
Page :

Start Your Coding Journey Now!